summaryrefslogtreecommitdiff
path: root/examples/example3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/example3/CMakeLists.txt')
-rwxr-xr-xexamples/example3/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/examples/example3/CMakeLists.txt b/examples/example3/CMakeLists.txt
new file mode 100755
index 0000000..52c4f8a
--- /dev/null
+++ b/examples/example3/CMakeLists.txt
@@ -0,0 +1,56 @@
+#######
+# Dlt - Diagnostic Log and Trace
+# @licence make begin@
+#
+# Copyright (C) 2011-2014, BMW AG - Alexander Wenzel <alexander.aw.wenzel@bmw.de>
+#
+# Contributions are licensed to the GENIVI Alliance under one or more
+# Contribution License Agreements.
+#
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
+# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# @licence end@
+########
+
+#
+# DLT example implementation
+#
+
+cmake_minimum_required( VERSION 2.6 )
+project( automotive-dlt-example3 )
+
+#
+# set prefix
+#
+
+set( CMAKE_INSTALL_PREFIX "/usr" )
+
+#
+# find dependency packages
+#
+
+find_package(PkgConfig)
+pkg_check_modules(DLT REQUIRED automotive-dlt)
+
+#
+# include directories
+#
+
+include_directories(
+ ${DLT_INCLUDE_DIRS}
+)
+
+#
+# build project
+#
+
+set(dlt_example3_SRCS example3.c)
+add_executable(dlt-example3 ${dlt_example3_SRCS})
+target_link_libraries(dlt-example3 ${DLT_LIBRARIES})
+set_target_properties(dlt-example3 PROPERTIES LINKER_LANGUAGE C)
+
+install(TARGETS dlt-example3
+ RUNTIME DESTINATION bin
+ COMPONENT base)