summaryrefslogtreecommitdiff
path: root/include/dlt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/dlt/CMakeLists.txt')
-rw-r--r--include/dlt/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/dlt/CMakeLists.txt b/include/dlt/CMakeLists.txt
index 9362821..ae05cc3 100644
--- a/include/dlt/CMakeLists.txt
+++ b/include/dlt/CMakeLists.txt
@@ -13,6 +13,10 @@
# For further information see http://www.genivi.org/.
#######
+if(WITH_DLT_DISABLE_MACRO)
+ set(DLT_DISABLE_MACRO 1)
+endif()
+
configure_file(dlt_user.h.in dlt_user.h)
set(HEADER_LIST dlt.h dlt_user_macros.h dlt_client.h dlt_protocol.h