summaryrefslogtreecommitdiff
path: root/include/dlt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/dlt/CMakeLists.txt')
-rw-r--r--include/dlt/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/include/dlt/CMakeLists.txt b/include/dlt/CMakeLists.txt
index 057af1f..d782d8a 100644
--- a/include/dlt/CMakeLists.txt
+++ b/include/dlt/CMakeLists.txt
@@ -15,13 +15,16 @@
# @licence end@
#######
-install(FILES dlt.h dlt_user.h dlt_user_macros.h dlt_client.h dlt_protocol.h dlt_common.h dlt_types.h dlt_version.h dlt_shm.h dlt_offline_trace.h dlt_filetransfer.h dlt_common_api.h
+install(FILES dlt.h dlt_user.h dlt_user_macros.h dlt_client.h dlt_protocol.h
+ dlt_common.h dlt_types.h dlt_shm.h dlt_offline_trace.h
+ dlt_filetransfer.h dlt_common_api.h
+ ${PROJECT_BINARY_DIR}/include/dlt/dlt_version.h
DESTINATION include/dlt
COMPONENT devel)
+if(WITH_DLT_CXX11_EXT)
+ install(FILES dlt_cpp_extension.hpp
+ DESTINATION include/dlt
+ COMPONENT devel)
+endif()
-if(${WITH_DLT_CXX11_EXT})
- install(FILES dlt_cpp_extension.hpp
- DESTINATION include/dlt
- COMPONENT devel)
-endif() \ No newline at end of file