summaryrefslogtreecommitdiff
path: root/include/dlt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/dlt/CMakeLists.txt')
-rw-r--r--include/dlt/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/dlt/CMakeLists.txt b/include/dlt/CMakeLists.txt
index ddf4717..460a410 100644
--- a/include/dlt/CMakeLists.txt
+++ b/include/dlt/CMakeLists.txt
@@ -13,10 +13,13 @@
# For further information see http://www.genivi.org/.
#######
-install(FILES dlt.h dlt_user.h dlt_user_macros.h dlt_client.h dlt_protocol.h
+configure_file(dlt_user.h.in dlt_user.h)
+
+install(FILES dlt.h dlt_user_macros.h dlt_client.h dlt_protocol.h
dlt_common.h dlt_types.h dlt_shm.h dlt_offline_trace.h
dlt_filetransfer.h dlt_common_api.h
- ${PROJECT_BINARY_DIR}/include/dlt/dlt_version.h
+ ${CMAKE_CURRENT_BINARY_DIR}/dlt_version.h
+ ${CMAKE_CURRENT_BINARY_DIR}/dlt_user.h
DESTINATION include/dlt
COMPONENT devel)