summaryrefslogtreecommitdiff
path: root/src/core_dump_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core_dump_handler/CMakeLists.txt')
-rw-r--r--src/core_dump_handler/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/core_dump_handler/CMakeLists.txt b/src/core_dump_handler/CMakeLists.txt
index 4545e93..96b6519 100644
--- a/src/core_dump_handler/CMakeLists.txt
+++ b/src/core_dump_handler/CMakeLists.txt
@@ -17,7 +17,7 @@
if(WITH_DLT_COREDUMPHANDLER)
- set( PLATFORM_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/${TARGET_CPU_NAME} )
+ set(PLATFORM_DIR ${PROJECT_SOURCE_DIR}/src/core_dump_handler/${TARGET_CPU_NAME})
set(dlt_cdh_SRCS dlt_cdh.c dlt_cdh_context.c dlt_cdh_coredump.c ${PLATFORM_DIR}/dlt_cdh_cpuinfo.c dlt_cdh_crashid.c dlt_cdh_streamer.c)
set(COREDUMP_CONF_DIR "/usr/lib/sysctl.d/")
@@ -25,21 +25,21 @@ if(WITH_DLT_COREDUMPHANDLER)
#add_definitions( -fno-strict-aliasing )
if(WITH_CITYHASH)
- set( CITYHASH_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/cityhash_c )
- add_definitions( -DHAS_CITYHASH_C )
- set(dlt_cdh_SRCS ${CITYHASH_DIR}/city_c.c ${dlt_cdh_SRCS} )
+ set(CITYHASH_DIR ${PROJECT_SOURCE_DIR}/src/core_dump_handler/cityhash_c)
+ add_definitions(-DHAS_CITYHASH_C)
+ set(dlt_cdh_SRCS ${CITYHASH_DIR}/city_c.c ${dlt_cdh_SRCS})
endif(WITH_CITYHASH)
add_executable(dlt-cdh ${dlt_cdh_SRCS})
target_link_libraries(dlt-cdh z)
set_target_properties(dlt-cdh PROPERTIES LINKER_LANGUAGE C)
- configure_file(${CMAKE_SOURCE_DIR}/src/core_dump_handler/50-coredump.conf.cmake ${PROJECT_BINARY_DIR}/core_dump_handler/50-coredump.conf)
+ configure_file(${PROJECT_SOURCE_DIR}/src/core_dump_handler/50-coredump.conf.cmake ${PROJECT_BINARY_DIR}/core_dump_handler/50-coredump.conf)
install(TARGETS dlt-cdh
RUNTIME DESTINATION bin
COMPONENT base)
- install(FILES ${PROJECT_BINARY_DIR}/core_dump_handler/50-coredump.conf DESTINATION ${COREDUMP_CONF_DIR} )
+ install(FILES ${PROJECT_BINARY_DIR}/core_dump_handler/50-coredump.conf DESTINATION ${COREDUMP_CONF_DIR})
endif(WITH_DLT_COREDUMPHANDLER)