summaryrefslogtreecommitdiff
path: root/src/daemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/CMakeLists.txt')
-rw-r--r--src/daemon/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/src/daemon/CMakeLists.txt b/src/daemon/CMakeLists.txt
index a2f6e38..e9fb2ba 100644
--- a/src/daemon/CMakeLists.txt
+++ b/src/daemon/CMakeLists.txt
@@ -45,15 +45,6 @@ install(TARGETS dlt-daemon
COMPONENT base)
if (WITH_DLT_UNIT_TESTS)
- if (WITH_DLT_FILTER_BACKEND_PROP)
- add_library(dlt_daemon ${dlt_daemon_SRCS} ${dlt_prop_backend_SRCS} ${systemd_SRCS})
- target_link_libraries(dlt_daemon ald_plugin rt ${CMAKE_THREAD_LIBS_INIT})
- install(TARGETS dlt_daemon
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/static
- COMPONENT base)
- else()
add_library(dlt_daemon ${dlt_daemon_SRCS})
target_link_libraries(dlt_daemon ${RT_LIBRARY} ${SOCKET_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
install(TARGETS dlt_daemon
@@ -61,7 +52,6 @@ if (WITH_DLT_UNIT_TESTS)
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/static
COMPONENT base)
- endif(WITH_DLT_FILTER_BACKEND_PROP)
endif(WITH_DLT_UNIT_TESTS)
INSTALL(FILES dlt.conf