summaryrefslogtreecommitdiff
path: root/src/system/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/system/CMakeLists.txt')
-rw-r--r--src/system/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
index ce87914..5b14508 100644
--- a/src/system/CMakeLists.txt
+++ b/src/system/CMakeLists.txt
@@ -35,6 +35,8 @@ install(TARGETS dlt-system
RUNTIME DESTINATION bin
COMPONENT base)
-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt-system.conf
- DESTINATION /etc
- COMPONENT base)
+if(NOT CMAKE_INSTALL_PREFIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt-system.conf DESTINATION /etc COMPONENT base)
+else(CMAKE_INSTALL_PREFIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt-system.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/etc COMPONENT base)
+endif(NOT CMAKE_INSTALL_PREFIX)