summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..4174e7f
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Setup testing
+enable_testing()
+find_package(GTest)
+include_directories(${gtest_SOURCE_DIR}/include)
+
+add_executable(hello hello.cpp)
+
+# Link test executable against gtest & gtest_main
+target_link_libraries(hello gtest gtest_main dlt)
+