summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2010-05-21 09:43:47 -0700
committerDan Williams <dcbw@redhat.com>2010-05-21 09:43:47 -0700
commitafebde48683392ccf54f9bd901ab5ac471e94dcb (patch)
treefb005178cd9ed647bfa6cdfbb674cb76dc2e6a07 /configure.ac
parentc311c3419cce6cd6c9ce87fd321b4fbbe6666e6d (diff)
downloadModemManager-afebde48683392ccf54f9bd901ab5ac471e94dcb.tar.gz
build: print version on startup and add dist-version
Distributions should set dist-version at build time with the package version and revision, so for RPM-based distros you'd --with-dist-version=%{version}-%{release} which will be printed out on MM startup to help debugging.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5b4478645..14cb2a062 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,6 +126,14 @@ else
fi
AM_CONDITIONAL(WITH_LOCATION_API, test "x$with_location_api" = "xyes")
+dnl
+dnl Distribution version string
+dnl
+AC_ARG_WITH(dist-version, AS_HELP_STRING([--with-dist-version=<mm-dist-version>], [Define the custom version (like distribution package name and revision)]), ac_distver=$withval, ac_distver="")
+if ! test x"$ac_distver" = x""; then
+ AC_DEFINE_UNQUOTED(MM_DIST_VERSION, "$ac_distver", [Define the distribution version string])
+fi
+
AC_CONFIG_FILES([
Makefile
marshallers/Makefile