summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-11-15 12:15:07 +0100
committerThomas Haller <thaller@redhat.com>2016-11-18 16:40:25 +0100
commit3d3ce77bf6aa08489648e8e9c288299fc23b87b9 (patch)
tree20aef300947f7f6b9d1303d60c4d6164dd65eaa1 /Makefile.am
parent830564e175f940a221190022e5fbea6c6e9bac3b (diff)
downloadNetworkManager-3d3ce77bf6aa08489648e8e9c288299fc23b87b9.tar.gz
build: add dependency for generated files for libnm-glib
Although the generated files are part of BUILD_SOURCES, that only matters during `make all`.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ef4449ac01..9be1329f83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3742,6 +3742,11 @@ BUILT_SOURCES += \
libnm-glib/nm-vpn-plugin-glue.h \
libnm-glib/nm-secret-agent-glue.h
+libnm-glib/nm-vpn-plugin.c: libnm-glib/nm-vpn-plugin-glue.h
+libnm-glib/nm-secret-agent.c: libnm-glib/nm-secret-agent-glue.h
+
+$(libnm_glib_lib_c_real): $(libnm_glib_lib_h_pub_gen)
+
pkgconfig_DATA += \
libnm-glib/libnm-glib.pc \
libnm-glib/libnm-glib-vpn.pc