summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-03-23 17:18:33 +0100
committerLubomir Rintel <lkundrak@v3.sk>2017-03-23 17:41:04 +0100
commit96571ec621e5786e68075d4ba2f017da6d23e762 (patch)
tree9a42ba2738842268d7d0c5f7158222fe7004b0ae /Makefile.am
parente832461c0e8ff1c27993191592b21b7fb235b3dd (diff)
downloadNetworkManager-96571ec621e5786e68075d4ba2f017da6d23e762.tar.gz
build: ensure libnm-core is around before mkenums puts files there
It's not sufficient to make nm-core-enum-types.[ch] depend on the dirstamp, because they also depend on their own stamps that are to be placed in libnm-core. $ make libnm-core/nm-core-enum-types.h.stamp GEN libnm-core/nm-core-enum-types.h /bin/sh: libnm-core/nm-core-enum-types.h.tmp: No such file or directory ../../Makefile.glib:107: recipe for target 'libnm-core/nm-core-enum-types.h.stamp' failed make: *** [libnm-core/nm-core-enum-types.h.stamp] Error 1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f0e6a3664c..e231049f2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -517,8 +517,8 @@ nm_core_enum_types_sources = $(libnm_core_lib_h_pub_real)
nm_core_enum_types_MKENUMS_C_FLAGS = --identifier-prefix NM --fhead '\#include "nm-default.h"\n'
-$(libnm_core_lib_h_pub_mkenums): libnm-core/.dirstamp
-$(libnm_core_lib_c_mkenums): libnm-core/.dirstamp
+libnm-core/nm-core-enum-types.h.stamp: libnm-core/.dirstamp
+libnm-core/nm-core-enum-types.c.stamp: libnm-core/.dirstamp
$(dispatcher_libnm_dispatcher_core_la_OBJECTS): $(libnm_core_lib_h_pub_mkenums)
$(dispatcher_nm_dispatcher_OBJECTS): $(libnm_core_lib_h_pub_mkenums)