summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-11-23 18:25:12 +0100
committerThomas Haller <thaller@redhat.com>2016-11-24 16:55:00 +0100
commitab208d69da1aa607d41bfe2ff9be09b5b9cf75fb (patch)
tree001ee16108587180d5050fddebaa2b05af865ea2 /Makefile.am
parent2ac6c5a981474318108b18ea6b4f8ef03fd48581 (diff)
downloadNetworkManager-ab208d69da1aa607d41bfe2ff9be09b5b9cf75fb.tar.gz
build: fix lookup "nm-settings-docs-overrides.xml" for out-of-tree build
When building "libnm/nm-settings-docs.xml", we require "nm-settings-docs-overrides.xml". As we dist the overrides files, we must consult VPATH to locate the proper version of the file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 658959ab40..5df8266cde 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -870,14 +870,14 @@ libnm/nm-property-docs.xml: libnm/generate-setting-docs.py $(libnm_docs_sources)
--gir $(builddir)/libnm/NM-1.0.gir \
--output $@
-libnm/nm-settings-docs.xml: libnm/generate-setting-docs.py $(libnm_docs_sources) libnm/nm-settings-docs-overrides.xml | libnm/NM-1.0.gir libnm/NM-1.0.typelib libnm/libnm.la
+libnm/nm-settings-docs.xml: libnm/generate-setting-docs.py libnm/nm-settings-docs-overrides.xml $(libnm_docs_sources) | libnm/NM-1.0.gir libnm/NM-1.0.typelib libnm/libnm.la
$(AM_V_GEN) \
export GI_TYPELIB_PATH=$(abs_builddir)/libnm$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}; \
export LD_LIBRARY_PATH=$(abs_builddir)/libnm/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}; \
$(call set_sanitizer_env,$(abs_builddir)/libnm/.libs/libnm.so); \
$(srcdir)/libnm/generate-setting-docs.py \
--gir $(builddir)/libnm/NM-1.0.gir \
- --overrides $(builddir)/libnm/nm-settings-docs-overrides.xml \
+ --overrides $(word 2,$^) \
--output $@
libnm/nm-settings-keyfile-docs.xml: libnm/generate-plugin-docs.pl $(libnm_docs_sources)