summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-08-01 18:27:22 +0200
committerLubomir Rintel <lkundrak@v3.sk>2017-10-30 21:46:55 +0100
commit830a5a14cb29ca00b73a9623c1ea7c5cd92f4d00 (patch)
tree9029a46673428644c3f27053d44aa3311293211f /Makefile.am
parentd0cb2050f371824f3f660e52e2655334559671bd (diff)
downloadNetworkManager-830a5a14cb29ca00b73a9623c1ea7c5cd92f4d00.tar.gz
device: add support for OpenVSwitch devices
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bdb47f8629..1c7456d6f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2769,6 +2769,63 @@ check_local += check-local-devices-team
endif
###############################################################################
+# src/devices/ovs
+###############################################################################
+
+if WITH_OPENVSWITCH
+
+if HAVE_SYSTEMD
+
+systemdnmunitdir = $(systemdsystemunitdir)/NetworkManager.service.d
+systemdnmunit_DATA = \
+ data/NetworkManager-ovs.conf
+
+endif
+
+core_plugins += src/devices/ovs/libnm-device-plugin-ovs.la
+
+src_devices_ovs_libnm_device_plugin_ovs_la_SOURCES = \
+ src/devices/ovs/nm-ovsdb.c \
+ src/devices/ovs/nm-ovsdb.h \
+ src/devices/ovs/nm-ovs-factory.c \
+ src/devices/ovs/nm-device-ovs-interface.c \
+ src/devices/ovs/nm-device-ovs-interface.h \
+ src/devices/ovs/nm-device-ovs-port.c \
+ src/devices/ovs/nm-device-ovs-port.h \
+ src/devices/ovs/nm-device-ovs-bridge.c \
+ src/devices/ovs/nm-device-ovs-bridge.h
+
+src_devices_ovs_libnm_device_plugin_ovs_la_CPPFLAGS = \
+ -I$(srcdir)/src \
+ -I$(builddir)/src \
+ -I$(srcdir)/shared \
+ -I$(builddir)/shared \
+ -I$(builddir)/libnm-core \
+ -I$(srcdir)/libnm-core \
+ \
+ -DG_LOG_DOMAIN=\""NetworkManager"\" \
+ -DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_INSIDE_DAEMON \
+ -DRUNSTATEDIR=\"$(runstatedir)\" \
+ \
+ $(JANSSON_CFLAGS) \
+ $(GLIB_CFLAGS)
+
+src_devices_ovs_libnm_device_plugin_ovs_la_LDFLAGS = \
+ -module -avoid-version \
+ -Wl,--version-script="$(srcdir)/linker-script-devices.ver"
+
+src_devices_ovs_libnm_device_plugin_ovs_la_LIBADD = \
+ introspection/libnmdbus.la \
+ $(JANSSON_LIBS) \
+ $(GLIB_LIBS)
+
+check-local-devices-ovs: src/devices/ovs/libnm-device-plugin-ovs.la
+ $(srcdir)/tools/check-exports.sh $(builddir)/src/devices/ovs/.libs/libnm-device-plugin-ovs.so "$(srcdir)/linker-script-devices.ver"
+ $(call check_so_symbols,$(builddir)/src/devices/ovs/.libs/libnm-device-plugin-ovs.so)
+
+endif
+
+###############################################################################
# src/dnsmasq/tests
###############################################################################