summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-12-28 15:31:23 +0100
committerThomas Haller <thaller@redhat.com>2019-01-02 11:51:42 +0100
commitef53b47e7c480fdfb981e27506f7fa0ee5604f78 (patch)
treee262e59bf2d2c4a607743d1a089dcae91e418682 /Makefile.am
parent600f8ee5cc5cab5d897501c46ee0d4f0f2371aa1 (diff)
downloadNetworkManager-ef53b47e7c480fdfb981e27506f7fa0ee5604f78.tar.gz
shared,core: move logging enums to header "shared/nm-utils/nm-logging-fwd.h"
In core ("src/"), we use "nm-logging.h" for all logging. This dispatches for logging to syslog, glog or systemd-journald. If we want to log from a shared component under "shared/", we need to use a common logging function. Add "nm-utils/nm-logging-fwd.h" for forward declaring the used logging mechaism. The shared library will still need to link with "src/nm-logging.c" or an alternative implementation, depending on whether it is used inside core or not.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1378c0348..f16cafd38d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -309,6 +309,7 @@ shared_nm_utils_libnm_utils_base_la_SOURCES = \
shared/nm-utils/nm-hash-utils.h \
shared/nm-utils/nm-io-utils.c \
shared/nm-utils/nm-io-utils.h \
+ shared/nm-utils/nm-logging-fwd.h \
shared/nm-utils/nm-macros-internal.h \
shared/nm-utils/nm-obj.h \
shared/nm-utils/nm-random-utils.c \