summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2009-02-15 11:20:25 -0500
committerDan Williams <dcbw@redhat.com>2009-02-15 11:20:25 -0500
commit73659e724c80504e2bd581bc9417d26b795597e2 (patch)
treebd542c6801c26601f89ee6abf1dc2c41ab4f8d7e /Makefile.am
parentc100d0d77913d644764186a661a94d2e5bfaa249 (diff)
downloadNetworkManager-73659e724c80504e2bd581bc9417d26b795597e2.tar.gz
makefile cleanups
0.7 requires dbus 1.1 or greater (for system bus activation), so make that explicit, and remove compat code for D-Bus 0.6 and earlier. Consolidate the various glib pkgconfig checks into one, since most anything will require gthread, glib, and gobject anyway. Fixup the docs makefile to be more automake-compatible and let 'make clean' actually work correctly when docs are built.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 17 insertions, 41 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ff0683c8d..2509206126 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,26 +1,3 @@
-if WITH_DOCS
-
-all:
-
-XSLTPROC = xsltproc --xinclude --nonet
-
-XMLS = $(wildcard introspection/nm-*.xml)
-# Figure out if we need ASYNC_INTROSPECT and add it later
-
-GENERATED_FILES = \
- docs/spec.html
-
-docs/spec.html: $(XMLS) introspection/all.xml introspection/generic-types.xml introspection/errors.xml introspection/vpn-errors.xml tools/doc-generator.xsl introspection/generic-types.xml
- @install -d docs
- $(XSLTPROC) tools/doc-generator.xsl introspection/all.xml > $@
-
-all: $(GENERATED_FILES)
-
-clean:
- rm -f $(GENERATED_FILES)
-
-endif
-
SUBDIRS = marshallers
if NO_GIO
@@ -28,30 +5,29 @@ SUBDIRS += gfilemonitor
endif
SUBDIRS += \
- libnm-util \
- libnm-glib \
- src \
- initscript \
- test \
- po \
- man \
- include \
- introspection \
+ libnm-util \
+ libnm-glib \
+ src \
+ include \
+ introspection \
callouts \
system-settings \
tools \
policy \
- docs/libnm-glib \
- docs/libnm-util
-
-EXTRA_DIST = \
- CONTRIBUTING \
- NetworkManager.pc.in \
- intltool-extract.in \
- intltool-merge.in \
+ initscript \
+ test \
+ po \
+ man \
+ docs
+
+EXTRA_DIST = \
+ CONTRIBUTING \
+ NetworkManager.pc.in \
+ intltool-extract.in \
+ intltool-merge.in \
intltool-update.in
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --with-tests=yes
+DISTCHECK_CONFIGURE_FLAGS = --with-tests=yes --with-docs=yes
DISTCLEANFILES = intltool-extract intltool-merge intltool-update