summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-09-20 13:29:42 +0200
committerThomas Haller <thaller@redhat.com>2022-09-23 11:43:33 +0200
commit231671fd02352773cd7a3274f99a825052c66a26 (patch)
tree60725cebaa0af299cb4f96724fc8d33755d540d0 /Makefile.am
parentdd2e1bc1cd913dd88fce8eb2f6a94cf3adfd8b5c (diff)
downloadNetworkManager-231671fd02352773cd7a3274f99a825052c66a26.tar.gz
all: add src/nm-compat-headers for patching included system headers
We already have src/linux-headers, where we have complete copies of linux user space headers. Of course that exists, because we want to use certain features and don't depend on the installed kernel headers. Which works well, because kernel user space API is stable, and we anyway want to support compiling against a newer kernel and run against an older (e.g. in a container). So having our copy of newer kernel headers is merely as if we compiled against as newer kernel. Add "src/nm-compat-headers" which has a similar purpose, but a different approach. Instead of replacing the included header entirely, include the system header and patch it with #define. Use this for "linux/if_addr.h". Of course, the approach here is that we no longer include <linux/if_addr.h> directly, but instead include "nm-compat-headers/linux/if_addr.h".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c40e1d2112..843ad3cfcb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -596,6 +596,8 @@ src_libnm_platform_libnm_platform_la_SOURCES = \
src/linux-headers/nl80211-vnd-intel.h \
src/linux-headers/nl802154.h \
\
+ src/nm-compat-headers/linux/if_addr.h \
+ \
src/libnm-platform/nm-linux-platform.c \
src/libnm-platform/nm-linux-platform.h \
src/libnm-platform/nm-netlink.c \