summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-10-17 14:09:13 +0200
committerThomas Haller <thaller@redhat.com>2018-10-18 12:16:55 +0200
commita6add8175a150f9bf64ac0b27064dc0d736aea6a (patch)
treeb6a77fd72f1dd51fcb84d0be58c433ec22261e93 /Makefile.am
parent884ed152618c669eebf21503822b9090f53162a3 (diff)
downloadNetworkManager-a6add8175a150f9bf64ac0b27064dc0d736aea6a.tar.gz
shared: move nm_utils_get_monotonic_timestamp*() to shared/nm-utils.
This is independent functionality that only depends on linux API and glib. Note how "nm-logging" uses this for getting the timestamps. This makes "nm-logging.c" itself dependen on "src/nm-core-utils.c", for little reason.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c1af3a0e2..da4c229d3f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1578,6 +1578,9 @@ src_libNetworkManagerBase_la_CPPFLAGS = $(src_cppflags)
src_libNetworkManagerBase_la_SOURCES = \
\
+ shared/nm-utils/nm-time-utils.c \
+ shared/nm-utils/nm-time-utils.h \
+ \
src/nm-core-utils.c \
src/nm-core-utils.h \
src/nm-logging.c \