summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2017-10-12 15:04:58 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2017-10-16 17:25:35 +0200
commitaa964ae96928901cfa49584dce20f50d8bdbce65 (patch)
tree08220fed457d7c92d8b37548b91d6b201a673c29 /Makefile.am
parentaec559cea5fd45bb77b2e4bec44a225e1107e833 (diff)
downloadNetworkManager-aa964ae96928901cfa49584dce20f50d8bdbce65.tar.gz
build: move nm-client-utils.c to libnmc-base.a
In a later commit we'll add a new generic client function used by nmcli and nmtui. nm-client-utils.c seems the right place for it, so move the file to the base library that is used by both clients. While at it, also put in that file some functions that will be needed by nmtui.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bce597e99..06cceb344e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3191,7 +3191,9 @@ clients_common_libnmc_base_la_SOURCES = \
clients/common/nm-secret-agent-simple.c \
clients/common/nm-secret-agent-simple.h \
clients/common/nm-vpn-helpers.c \
- clients/common/nm-vpn-helpers.h
+ clients/common/nm-vpn-helpers.h \
+ clients/common/nm-client-utils.c \
+ clients/common/nm-client-utils.h
clients_common_libnmc_base_la_CPPFLAGS = \
$(clients_cppflags) \
@@ -3242,8 +3244,6 @@ clients_common_libnmc_la_SOURCES = \
shared/nm-meta-setting.c \
shared/nm-meta-setting.h \
\
- clients/common/nm-client-utils.c \
- clients/common/nm-client-utils.h \
clients/common/nm-meta-setting-desc.c \
clients/common/nm-meta-setting-desc.h \
clients/common/nm-meta-setting-access.c \