summaryrefslogtreecommitdiff
path: root/clients/cloud-setup/meson.build
diff options
context:
space:
mode:
authorSayed Shah <sayshah@redhat.com>2020-07-13 14:29:22 -0400
committerThomas Haller <thaller@redhat.com>2020-07-29 15:56:15 +0200
commite7ac7290bd04f0607095214f2816d096ab737011 (patch)
tree90bb50487070f914c3d969396816afc42beb24b3 /clients/cloud-setup/meson.build
parentc904736d96a41899f619956931f2d5412bc866a2 (diff)
downloadNetworkManager-e7ac7290bd04f0607095214f2816d096ab737011.tar.gz
cloud-setup: add tool for automatic IP configuration in cloud
This is a tool for automatically configuring networking in azure cloud environment. This add a provider implementation for Azure that when detected fetches the private ip addressess and the subnet prefix of configured internal load balancers. Once this information is fetched from the metadata server, it instructs NetworkManager to add private ip addressess and subnet prefix for each interface detected. It is inspired by SuSE's cloud-netconfig ([1], [2]) and Azure Instance Metadata service [3]. [1] https://www.suse.com/c/multi-nic-cloud-netconfig-ec2-azure/ [2] https://github.com/SUSE-Enceladus/cloud-netconfig [3] https://docs.microsoft.com/en-us/azure/virtual-machines/linux/instance-metadata-service It is also intended to work without configuration. The main point is that you boot an image with NetworkManager and nm-cloud-setup enabled, and it just works. https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/572
Diffstat (limited to 'clients/cloud-setup/meson.build')
-rw-r--r--clients/cloud-setup/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/clients/cloud-setup/meson.build b/clients/cloud-setup/meson.build
index 805d46813b..c29d73df06 100644
--- a/clients/cloud-setup/meson.build
+++ b/clients/cloud-setup/meson.build
@@ -29,6 +29,7 @@ sources = files(
'nm-http-client.c',
'nmcs-provider-ec2.c',
'nmcs-provider-gcp.c',
+ 'nmcs-provider-azure.c',
'nmcs-provider.c',
)