summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2013-05-06 14:18:26 -0400
committerDan Winship <danw@gnome.org>2013-05-08 15:07:18 -0400
commitc4417c71b64fd11064184676ca73b51c05c20e3f (patch)
tree62164464032a0e8c1133e77c9b2f995274a08525 /configure.ac
parent6c2a35a090d25e3ff05c8b3c07191be6324ddc70 (diff)
downloadNetworkManager-c4417c71b64fd11064184676ca73b51c05c20e3f.tar.gz
core: use non-recursive build
Although having different parts of NM in different subdirectories keeps the source tree neat, it has made the build messy, particularly because of cross-dependencies between the subdirs. Reorganize to build all of the pieces of the NetworkManager binary from src/Makefile, and only use recursive make for test programs, helper binaries, and plugins. As part of this, get rid of all the per-directory convenience libraries, and switch to building a single top-level libNetworkManager.la, containing everything except main.c, which all of the test programs can then link against.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 1 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 5e8a3e7a98..8d3276bb48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -639,7 +639,7 @@ AS_IF([test "$with_valgrind" == "yes"],
AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" != "no")
AM_CONDITIONAL(RUN_ROOT_TESTS, test "$enable_tests" == "root")
AS_IF([test "$with_valgrind" != "no"],
- AC_SUBST(VALGRIND_RULES, "TESTS_ENVIRONMENT = G_SLICE=always-malloc G_DEBUG=gc-friendly $with_valgrind --quiet --error-exitcode=1 --leak-check=full --gen-suppressions=all --suppressions=\$(top_srcdir)/valgrind.suppressions"),
+ AC_SUBST(VALGRIND_RULES, "TESTS_ENVIRONMENT = G_SLICE=always-malloc G_DEBUG=gc-friendly \$(LIBTOOL) --mode=execute $with_valgrind --quiet --error-exitcode=1 --leak-check=full --gen-suppressions=all --suppressions=\$(top_srcdir)/valgrind.suppressions"),
AC_SUBST(VALGRIND_RULES, []))
AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" = "yes")
# Add gtk-doc conditionals
@@ -652,25 +652,11 @@ include/Makefile
include/nm-version.h
src/Makefile
src/tests/Makefile
-src/generated/Makefile
-src/logging/Makefile
-src/config/Makefile
src/config/tests/Makefile
-src/posix-signals/Makefile
-src/dns-manager/Makefile
-src/vpn-manager/Makefile
src/dhcp-manager/Makefile
src/dhcp-manager/tests/Makefile
-src/ip6-manager/Makefile
-src/supplicant-manager/Makefile
src/supplicant-manager/tests/Makefile
src/ppp-manager/Makefile
-src/dnsmasq-manager/Makefile
-src/modem-manager/Makefile
-src/bluez-manager/Makefile
-src/wifi/Makefile
-src/firewall-manager/Makefile
-src/settings/Makefile
src/settings/plugins/Makefile
src/settings/plugins/ifupdown/Makefile
src/settings/plugins/ifupdown/tests/Makefile
@@ -685,7 +671,6 @@ src/settings/plugins/keyfile/tests/Makefile
src/settings/plugins/keyfile/tests/keyfiles/Makefile
src/settings/plugins/example/Makefile
src/settings/tests/Makefile
-src/platform/Makefile
src/platform/tests/Makefile
src/wimax/Makefile
libnm-util/libnm-util.pc