summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@redhat.com>2015-04-13 17:07:00 -0400
committerDan Winship <danw@redhat.com>2015-04-17 12:42:23 -0400
commit721e917cb6c3f6bea7e856aaed0cd49626887db1 (patch)
treea82b3d538b0dba1ad5a6b40731980802dbfd48a9 /configure.ac
parenta858b383c348c2a43e63be325156b68e3789441a (diff)
downloadNetworkManager-721e917cb6c3f6bea7e856aaed0cd49626887db1.tar.gz
wimax: drop WiMAX support (bgo #747846)
Even Fedora is no longer shipping the WiMAX SDK, so it's likely we'll eventually accidentally break some of the code in src/devices/wimax/ (if we haven't already). Discussion on the list showed a consensus for dropping support for WiMAX. So, remove the SDK checks from configure.ac, remove the WiMAX device plugin and associated manager support, and deprecate all the APIs. For compatibility reasons, it is still possible to create and save WiMAX connections, to toggle the software WiMAX rfkill state, and to change the "WIMAX" log level, although none of these have any effect, since no NMDeviceWimax will ever be created. nmcli was only compiling in support for most WiMAX operations when NM as a whole was built with WiMAX support, so that code has been removed now as well. (It is still possible to use nmcli to create and edit WiMAX connections, but those connections will never be activatable.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index e2a452bf83..436db10cc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,31 +472,6 @@ AC_SUBST(UUID_LIBS)
dnl Checks for readline library - used by nmcli
AX_LIB_READLINE
-# Intel WiMAX SDK checks
-PKG_CHECK_MODULES(IWMX_SDK, [libiWmxSdk-0 >= 1.5.1], [have_wimax=yes],[have_wimax=no])
-AC_ARG_ENABLE(wimax, AS_HELP_STRING([--enable-wimax], [enable WiMAX support]),
- [enable_wimax=${enableval}], [enable_wimax=${have_wimax}])
-if (test "${enable_wimax}" = "yes"); then
- if test x"$have_wimax" = x"no"; then
- AC_MSG_ERROR(Intel WiMAX SDK is required)
- fi
-
- # Ensure the WiMAX stack is built with libnl3; otherwise crashes happen
- # due to symbol conflicts
- WMX_LIB_PATH=`$PKG_CONFIG --variable=libdir libiWmxSdk-0`
- FOO=`ldd $WMX_LIB_PATH/libiWmxSdk.so.0.0.0 | grep libnl-3 2>&1`
- if test "$?" != "0"; then
- AC_MSG_ERROR([Intel WiMAX stack built with incompatible libnl version!])
- fi
-
- AC_SUBST(IWMX_SDK_CFLAGS)
- AC_SUBST(IWMX_SDK_LIBS)
- AC_DEFINE(WITH_WIMAX, 1, [Define if you have WiMAX support])
-else
- AC_DEFINE(WITH_WIMAX, 0, [Define if you have WiMAX support])
-fi
-AM_CONDITIONAL(WITH_WIMAX, test "${enable_wimax}" = "yes")
-
# Teamd control checks
PKG_CHECK_MODULES(LIBTEAMDCTL, [libteamdctl >= 1.9], [have_teamdctl=yes],[have_teamdctl=no])
AC_ARG_ENABLE(teamdctl, AS_HELP_STRING([--enable-teamdctl], [enable Teamd control support]),
@@ -995,7 +970,6 @@ src/platform/tests/Makefile
src/rdisc/Makefile
src/rdisc/tests/Makefile
src/devices/adsl/Makefile
-src/devices/wimax/Makefile
src/devices/bluetooth/Makefile
src/devices/team/Makefile
src/devices/wifi/Makefile
@@ -1100,7 +1074,6 @@ echo
echo "Features:"
echo " wext: $ac_with_wext"
echo " wifi: $enable_wifi"
-echo " wimax: $enable_wimax"
echo " ppp: $enable_ppp"
echo " modemmanager-1: $with_modem_manager_1"
echo " concheck: $enable_concheck"