summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-02-24 12:58:55 +0100
committerThomas Haller <thaller@redhat.com>2017-02-24 13:06:13 +0100
commitc0d9243e7ebdb6efd5c3e866b03a28cd91b08c83 (patch)
tree73af5335013b9bc4fbb72a7ade4d089e7e7bf518 /configure.ac
parent360e80b75faead6595ceb4ca8cd91dd7fbaa2f47 (diff)
downloadNetworkManager-c0d9243e7ebdb6efd5c3e866b03a28cd91b08c83.tar.gz
session: make systemd-logind and elogind conflicting build optionsth/elogind-bgo779167
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c5d43e5525..e7d8878279 100644
--- a/configure.ac
+++ b/configure.ac
@@ -454,11 +454,14 @@ if test "$use_systemd_logind" = "yes" -a "$have_systemd_logind" = "no"; then
AC_MSG_ERROR([You must have libsystemd installed to build with systemd-logind support.])
fi
if test "$have_systemd_logind" = "yes"; then
- AC_DEFINE([SESSION_TRACKING_SYSTEMD], 1, [Define to 1 if libsystemd-login is available])
- session_tracking="$session_tracking, systemd-logind"
+ AC_DEFINE([SESSION_TRACKING_SYSTEMD], 1, [Define to 1 if libsystemd-login is available])
+ session_tracking="$session_tracking, systemd-logind"
fi
-if test "$use_elogind" = "yes" -o "$use_elogind" = "auto"; then
+if test "$use_elogind" = "yes" -a "$have_systemd_logind" = "yes"; then
+ AC_MSG_ERROR([Cannot enable systemd-logind together with elogind.])
+fi
+if test "$use_elogind" = "yes"; then
PKG_CHECK_MODULES(SYSTEMD_LOGIN, [libelogind], [have_elogind=yes], [PKG_CHECK_MODULES(SYSTEMD_LOGIN, [libelogind], [have_elogind=yes], [have_elogind=no])])
else
have_elogind=no