summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2017-02-21 16:26:49 +0100
committerBeniamino Galvani <bgalvani@redhat.com>2017-02-23 10:07:06 +0100
commit9dac51d9c0ac470c302973d2e3e49c6e62ddf95d (patch)
tree54810baca9758e4b62c2c86bebc17e7deaa75911 /configure.ac
parent029a0a21ea1ebf74a10253845396f06b0194853a (diff)
downloadNetworkManager-9dac51d9c0ac470c302973d2e3e49c6e62ddf95d.tar.gz
team: support the ethernet.cloned-mac-address property
The only reliable way of setting a MAC address for the team is through the "hwaddr" property in the configuration passed to teamd. In order to rewrite the configuration we need Jansson support; since it is already a requirement for teamd, let the team plugin depend on it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e8910a6fdf..354db306e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,11 +550,20 @@ PKG_CHECK_MODULES(UUID, uuid)
PKG_CHECK_MODULES(JANSSON, [jansson], [have_jansson=yes], [have_jansson=no])
PKG_CHECK_MODULES(LIBTEAMDCTL, [libteamdctl >= 1.9], [have_teamdctl=yes],[have_teamdctl=no])
+if test "$have_jansson" = "yes" -a "$have_teamdctl" = "yes"; then
+ have_team_prereq=yes
+else
+ have_team_prereq=no
+fi
+
AC_ARG_ENABLE(teamdctl, AS_HELP_STRING([--enable-teamdctl], [enable Teamd control support]),
- [enable_teamdctl=${enableval}], [enable_teamdctl=${have_teamdctl}])
+ [enable_teamdctl=${enableval}], [enable_teamdctl=${have_team_prereq}])
if (test "${enable_teamdctl}" = "yes"); then
- if test x"$have_teamdctl" = x"no"; then
- AC_MSG_ERROR(Teamd control is required)
+ if test "$have_teamdctl" = "no"; then
+ AC_MSG_ERROR(Libteamdctl is required for team support)
+ fi
+ if test "$have_jansson" = "no"; then
+ AC_MSG_ERROR(Jansson is required for team support)
fi
# temporary bug workaround
LIBTEAMDCTL_CFLAGS=`echo $LIBTEAMDCTL_CFLAGS | sed -e 's:/teamdctl.h::'`