summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2016-11-21 18:06:14 +0100
committerLubomir Rintel <lkundrak@v3.sk>2016-11-21 18:15:42 +0100
commitd3f7f7abca792c7de44e158f745849db23a5304f (patch)
treeb0d9c699d9791aad183a1825192f244d5d97f812 /configure.ac
parent3b64dc9cbdc5468e899429428ad1b65e27ab15fb (diff)
downloadNetworkManager-d3f7f7abca792c7de44e158f745849db23a5304f.tar.gz
all: drop YAML dependency
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index feaf025705..9963c4d104 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1109,20 +1109,8 @@ if test -n "$INTROSPECTION_MAKEFILE" -a "$enable_gtk_doc" = "yes"; then
# gtk-doc depends on perl, but we can check for it anyway
AC_PATH_PROG(PERL, perl, no)
- # check for needed perl modules (use YAML; YAML::XS is better, but may not be so widespread)
- required_perl_modules="YAML"
- for module in $required_perl_modules; do
- AC_MSG_CHECKING([checking for perl module '$module'])
- if ${PERL} -e 'use '$module 2>/dev/null ; then
- AC_MSG_RESULT([Ok])
- have_perl_modules=yes
- else
- AC_MSG_RESULT([Failed])
- AC_MSG_ERROR([You must have Perl modules to build settings plugin docs: $required_perl_modules.])
- fi
- done
-
- if test "$have_pyobject" = "yes" -a "$have_perl_modules" = "yes"; then
+
+ if test "$have_pyobject" = "yes"; then
AC_DEFINE(BUILD_SETTING_DOCS, [1], [Define if you we can build nm-setting-docs.xml, nm-keyfile-docs.xml and nm-ifcfg-rh-docs.xml])
build_setting_docs=yes
fi