summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancesco Giudici <fgiudici@redhat.com>2017-05-05 12:18:51 +0200
committerFrancesco Giudici <fgiudici@redhat.com>2017-05-10 09:19:47 +0200
commit170e6b777289b42eedc8c00dd6587236391d5117 (patch)
tree22976f1ba34c6a2ac43d16e6348222d839c53de6 /configure.ac
parent227bc5ed27ef671d10859850798236051a4e0988 (diff)
downloadNetworkManager-170e6b777289b42eedc8c00dd6587236391d5117.tar.gz
build: restore --enable-concheck as default if libcurl is detected
Recently we removed libsoup dependency in favor of libcurl. Connectivity checking functionality was enabled by defaut when libsoup was detected: do the same now when detecting libcurl. (cherry picked from commit ad35fbf3a33185e40a55245326dc22dbd499c90b)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b9726ac043..d82fc63298 100644
--- a/configure.ac
+++ b/configure.ac
@@ -973,10 +973,14 @@ else
fi
AM_CONDITIONAL(WITH_LIBPSL, test "$with_libpsl" != "no")
-AC_ARG_ENABLE(concheck, AS_HELP_STRING([--enable-concheck], [enable connectivity checking support]),
- [enable_concheck=${enableval}], [enable_concheck=${with_libcurl}])
-if (test "${enable_concheck}" = "yes"); then
- PKG_CHECK_MODULES(LIBCURL, [libcurl >= 7.24.0])
+PKG_CHECK_MODULES(LIBCURL, [libcurl >= 7.24.0], [have_libcurl=yes], [have_libcurl=no])
+AC_ARG_ENABLE(concheck,
+ AS_HELP_STRING([--enable-concheck], [enable connectivity checking support]),
+ [enable_concheck=${enableval}], [enable_concheck=${have_libcurl}])
+if test "${enable_concheck}" = "yes"; then
+ if test "$have_libcurl" != "yes"; then
+ AC_MSG_ERROR(Cannot find libcurl library required by concheck)
+ fi
AC_DEFINE(WITH_CONCHECK, 1, [Define if you want connectivity checking support])
else
enable_concheck=no