summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-08-01 18:27:22 +0200
committerLubomir Rintel <lkundrak@v3.sk>2017-10-30 21:46:55 +0100
commit830a5a14cb29ca00b73a9623c1ea7c5cd92f4d00 (patch)
tree9029a46673428644c3f27053d44aa3311293211f /configure.ac
parentd0cb2050f371824f3f660e52e2655334559671bd (diff)
downloadNetworkManager-830a5a14cb29ca00b73a9623c1ea7c5cd92f4d00.tar.gz
device: add support for OpenVSwitch devices
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a4353760a4..8ff914d0e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -871,6 +871,20 @@ if test "$with_dhcpcanon" != "no"; then
else
AC_DEFINE(WITH_DHCPCANON, 0, [Define if you have dhcpcanon])
fi
+
+# OpenVSwitch integration
+AC_ARG_ENABLE(ovs, AS_HELP_STRING([--enable-ovs], [enable OpenVSwitch support]))
+if test "${enable_ovs}" != "no"; then
+ enable_ovs='yes'
+ if test "$have_jansson" = "no"; then
+ AC_MSG_ERROR(Jansson is required for ovs support)
+ fi
+ AC_DEFINE(WITH_OPENVSWITCH, 1, [Define if you have OpenVSwitch support])
+else
+ AC_DEFINE(WITH_OPENVSWITCH, 0, [Define if you have OpenVSwitch support])
+fi
+AM_CONDITIONAL(WITH_OPENVSWITCH, test "${enable_ovs}" = "yes")
+
# DHCP client support
AC_ARG_WITH([dhclient],
AS_HELP_STRING([--with-dhclient=yes|no|path], [Enable dhclient 4.x support]))
@@ -1359,6 +1373,7 @@ echo " modemmanager-1: $with_modem_manager_1"
echo " ofono: $with_ofono"
echo " concheck: $enable_concheck"
echo " libteamdctl: $enable_teamdctl"
+echo " ovs: $enable_ovs"
echo " libnm-glib: $with_libnm_glib"
echo " nmcli: $build_nmcli"
echo " nmtui: $build_nmtui"