summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-10-18 14:01:56 +0200
committerThomas Haller <thaller@redhat.com>2016-10-21 17:37:57 +0200
commit14b5309af3fc4be3fcaf66703b879da090eb4ac4 (patch)
treef53dbe556ae3edffabc4446305eeb8e751c8a4de /configure.ac
parentb0f4e25782944744256bfc0ad01848ea5c7547c8 (diff)
downloadNetworkManager-14b5309af3fc4be3fcaf66703b879da090eb4ac4.tar.gz
build: merge "vapi/Makefile.am" into toplevel Makefile
There is an strange automake warning Makefile.vapigen:49: warning: $(1) was already defined in condition TRUE, which includes condition ENABLE_VAPIGEN ... Makefile.am:4: 'Makefile.vapigen' included from here Makefile.glib:124: ... '$(1)' previously defined here Makefile.am:1: 'Makefile.glib' included from here when having if ENABLE_VAPIGEN include Makefile.vapigen endif That is worked around by removing the "if", which however requires us to remove the error check in Makefile.vapigen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a1b1bd8d5..9a15e354f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1043,6 +1043,7 @@ dnl Vala bindings
dnl -------------------------
VAPIGEN_CHECK(0.17.1.24)
+AC_CONFIG_COMMANDS([vapi], [$MKDIR_P vapi])
# Tests, utilities and documentation
AC_ARG_ENABLE(tests, AS_HELP_STRING([--enable-tests=root|yes|no], [Build NetworkManager tests (default: yes)]))
@@ -1163,7 +1164,6 @@ examples/C/Makefile
examples/C/glib/Makefile
examples/C/qt/Makefile
examples/dispatcher/Makefile
-vapi/Makefile
])
AC_CONFIG_SUBDIRS([libndp])
AC_OUTPUT