summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martinpitt@gnome.org>2013-04-26 14:48:34 +0200
committerDan Winship <danw@gnome.org>2013-04-26 10:52:24 -0400
commit39a0c81aa5c9e2585b3b35779320d5bcd3ce4e7c (patch)
treef123d47298079efd4001841c9875801d0be6abcd /configure.ac
parent190d8aa8407b6b930fc2cad7200e92dd2bffe9a6 (diff)
downloadNetworkManager-39a0c81aa5c9e2585b3b35779320d5bcd3ce4e7c.tar.gz
configure: Check libsystemd-login version for suspend-resume
Some distributions (Debian and Ubuntu in particular) will soon use systemd's logind, but not its init part. Check for a recent enough "libsystemd-login" version instead of "systemd", as suspend/resume and inhibitors are all in logind. https://bugzilla.gnome.org/show_bug.cgi?id=698947
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 54a3504ee0..43372a10b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,7 +308,7 @@ AC_MSG_RESULT($with_session_tracking)
AC_ARG_WITH(suspend-resume, AS_HELP_STRING([--with-suspend-resume=upower|systemd], [Build NetworkManager with specific suspend/resume support]))
if test "z$with_suspend_resume" = "z"; then
- PKG_CHECK_EXISTS([systemd >= 183], [have_systemd_inhibit=yes], [have_systemd_inhibit=no])
+ PKG_CHECK_EXISTS([libsystemd-login >= 183], [have_systemd_inhibit=yes], [have_systemd_inhibit=no])
if test "z${have_systemd_inhibit}" = "zyes"; then
# Use systemd if it's new enough
with_suspend_resume="systemd"
@@ -321,7 +321,7 @@ fi
case $with_suspend_resume in
upower) ;;
systemd)
- PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [systemd >= 183])
+ PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [libsystemd-login >= 183])
;;
*)
AC_MSG_ERROR(--with-suspend-resume must be one of [upower, systemd])