summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2018-06-15 12:09:07 +0200
committerLubomir Rintel <lkundrak@v3.sk>2018-06-15 13:07:53 +0200
commitdf58895fb3479c4f00b9107126759d138250fef2 (patch)
tree192e8536b2198c232727a7ba7632df35f1bffd83 /configure.ac
parent576cbb771aafce4a1aeceb9ee99bffbdd63164e7 (diff)
downloadNetworkManager-df58895fb3479c4f00b9107126759d138250fef2.tar.gz
build: disable libnm-glib by default
It's deprecated and has been replaced by libnm for 6 major releases now. Its use in modern distributions has faded to the point it can probably be safely removed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 23cf8019aa..0ca1248bf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,26 +256,26 @@ AC_SUBST(GLIB_LIBS)
GOBJECT_INTROSPECTION_CHECK([0.9.6])
AC_ARG_WITH(libnm-glib,
- AS_HELP_STRING([--without-libnm-glib],
- [don"'"t build legacy libraries]))
+ AS_HELP_STRING([--with-libnm-glib],
+ [build legacy libraries]))
fake_typelibs=no
-if test "$with_libnm_glib" != "no"; then
+if test "$with_libnm_glib" == "yes"; then
PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.1 dbus-glib-1 >= 0.94, :,
[AC_MSG_FAILURE([$DBUS_PKG_ERRORS
Configure with --without-libnm-glib if you do not need the legacy libraries])
])
- with_libnm_glib=yes
-
if test "${found_introspection}" = "yes"; then
AC_PATH_PROG(GLIB_COMPILE_RESOURCES, glib-compile-resources)
if ! test x"$GLIB_COMPILE_RESOURCES" = x""; then
fake_typelibs=yes
fi
fi
+else
+ with_libnm_glib=no
fi
-AM_CONDITIONAL(WITH_LEGACY_LIBRARIES, test "$with_libnm_glib" != "no")
+AM_CONDITIONAL(WITH_LEGACY_LIBRARIES, test "$with_libnm_glib" == "yes")
if test "$fake_typelibs" = "yes"; then
AC_DEFINE(WITH_FAKE_TYPELIBS, 1, [Define for libnm to prevent GIR from loading libnm-glib])
else