summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2013-10-31 09:14:13 +0100
committerDan Winship <danw@gnome.org>2014-02-13 12:06:17 -0500
commit3b76ae18a52b44dbe577557e038fdc263edc5715 (patch)
treefe227fb22c4474e7ebba679bc55797e07c6e46a4 /configure.ac
parent64c5395cb1cc9e491b96b6bb86df72cb3c606627 (diff)
downloadNetworkManager-3b76ae18a52b44dbe577557e038fdc263edc5715.tar.gz
modem-manager: if building systemd support, assume it manages the MM lifecycle
We will not explicitly poke MM to start it if NetworkManager is built with systemd support. https://bugzilla.gnome.org/show_bug.cgi?id=703040
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 174b6bfa20..895ab09a23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,6 +304,9 @@ AS_IF([test -z "$with_systemdsystemunitdir"], with_systemdsystemunitdir=no)
AM_CONDITIONAL(HAVE_SYSTEMD, [test "$with_systemdsystemunitdir" != no])
if test "$with_systemdsystemunitdir" != no; then
AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+ AC_DEFINE(HAVE_SYSTEMD, 1, [Define if systemd support is available])
+else
+ AC_DEFINE(HAVE_SYSTEMD, 0, [Define if systemd support is available])
fi
PKG_CHECK_MODULES(SYSTEMD_200, [systemd >= 200], [have_systemd_200=yes],[have_systemd_200=no])