summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-04-04 11:19:40 -0400
committerDan Winship <danw@gnome.org>2014-04-14 10:11:05 -0400
commitebc5ea0b80072b5026d8fb220208befd00bdd2c3 (patch)
tree9b432d3a6407dd45c755cd0666ee652c21bbadd7 /configure.ac
parent3e58107fe04dc3949d98c5b962a3f3da8b453e71 (diff)
downloadNetworkManager-ebc5ea0b80072b5026d8fb220208befd00bdd2c3.tar.gz
ppp-manager: find pppd at build time, allow overriding
Add --with-pppd, just like --with-dnsmasq. Also change "ppp" to "pppd" for clarity in a few places.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2ca6aed586..4f51831075 100644
--- a/configure.ac
+++ b/configure.ac
@@ -537,6 +537,15 @@ else
fi
AC_SUBST(PPPD_PLUGIN_DIR)
+AC_ARG_WITH(pppd, AS_HELP_STRING([--with-pppd=/path/to/pppd], [path to pppd binary]))
+if test "x${with_pppd}" = x; then
+ AC_PATH_PROG(PPPD_PATH, pppd, [], $PATH:/sbin:/usr/sbin)
+else
+ PPPD_PATH="$with_pppd"
+fi
+AC_DEFINE_UNQUOTED(PPPD_PATH, "$PPPD_PATH", [Define to path of pppd binary])
+AC_SUBST(PPPD_PATH)
+
# ModemManager1 with libmm-glib
AC_ARG_WITH(modem-manager-1, AS_HELP_STRING([--with-modem-manager-1], [Enable new ModemManager1 interface support]),,[with_modem_manager_1=auto])
if (test "${with_modem_manager_1}" != "no"); then