summaryrefslogtreecommitdiff
path: root/docs/libnm/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-07-24 08:59:21 -0400
committerDan Winship <danw@gnome.org>2014-08-01 14:34:05 -0400
commitc5daa4c4df07d413e5f760eac5a2f686f6062225 (patch)
tree2f79faac6c07d2e449dea95c65c2542aca5f609d /docs/libnm/Makefile.am
parenteedcf185a7615c68281f2dc33f315efbaeee93c8 (diff)
downloadNetworkManager-c5daa4c4df07d413e5f760eac5a2f686f6062225.tar.gz
docs: add libnm documentation
Add docs infrastructure
Diffstat (limited to 'docs/libnm/Makefile.am')
-rw-r--r--docs/libnm/Makefile.am84
1 files changed, 84 insertions, 0 deletions
diff --git a/docs/libnm/Makefile.am b/docs/libnm/Makefile.am
new file mode 100644
index 0000000000..9d745b14c2
--- /dev/null
+++ b/docs/libnm/Makefile.am
@@ -0,0 +1,84 @@
+## Process this file with automake to produce Makefile.in
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module
+DOC_MODULE=libnm
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting functions and macros.
+DOC_SOURCE_DIR=$(top_srcdir)/libnm-core $(top_srcdir)/libnm
+
+# Extra options to supply to gtkdoc-scan.
+SCAN_OPTIONS=--rebuild-types --rebuild-sections
+
+# Extra options to supply to gtkdoc-scangobj.
+SCANGOBJ_OPTIONS=--type-init-func 'g_type_init();'
+
+# Extra options to supply to gtkdoc-mkdb.
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-fixref.
+FIXXREF_OPTIONS=
+
+# Used for dependencies.
+HFILE_GLOB=$(top_srcdir)/libnm-core/*.h $(top_srcdir)/libnm/*.h
+CFILE_GLOB=$(top_srcdir)/libnm-core/*.c $(top_srcdir)/libnm/*.c
+
+# Header files to ignore when scanning.
+IGNORE_HFILES= \
+ crypto.h \
+ nm-dbus-helpers-private.h \
+ nm-device-private.h \
+ nm-object-cache.h \
+ nm-object-private.h \
+ nm-param-spec-dbus.h \
+ nm-remote-connection-private.h \
+ nm-secret-agent-glue.h \
+ nm-setting-private.h \
+ nm-types-private.h \
+ nm-utils-private.h \
+ nm-vpn-plugin-glue.h
+
+# Images to copy into HTML directory.
+HTML_IMAGES = libnm.png
+
+# Extra XML files that are included by $(DOC_MAIN_SGML_FILE).
+content_files = version.xml
+
+# Other files to distribute.
+extra_files = libnm.png
+
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+GTKDOC_CFLAGS = \
+ -I$(top_srcdir)/libnm-core \
+ -I$(top_builddir)/libnm-core \
+ -I$(top_srcdir)/libnm \
+ -I$(top_builddir)/libnm \
+ -DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
+ $(GLIB_CFLAGS) \
+ $(DBUS_CFLAGS)
+
+GTKDOC_LIBS = \
+ $(top_builddir)/libnm/libnm.la \
+ $(top_builddir)/libnm/libnm-vpn.la \
+ $(GLIB_LIBS)
+
+
+# include common portion ...
+include $(top_srcdir)/gtk-doc.make
+
+EXTRA_DIST += version.xml.in
+
+CLEANFILES += \
+ libnm-sections.txt \
+ libnm-overrides.txt \
+ html/* \
+ tmpl/* \
+ xml/*
+