summaryrefslogtreecommitdiff
path: root/docs/libnm/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-25 11:39:06 +0100
committerThomas Haller <thaller@redhat.com>2017-12-13 15:48:50 +0100
commit03637ad8b5d21fcc12a536a25caf46445aabde73 (patch)
tree3330fed2a9ad0f45c0c993a8aac6d3dee42ed101 /docs/libnm/meson.build
parente96fabfc186510808cee1bf6aaaa28f460f1cea5 (diff)
downloadNetworkManager-03637ad8b5d21fcc12a536a25caf46445aabde73.tar.gz
build: add initial support for meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. [thaller@redhat.com: rebased patch and adjusted for iwd support] https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00022.html
Diffstat (limited to 'docs/libnm/meson.build')
-rw-r--r--docs/libnm/meson.build55
1 files changed, 55 insertions, 0 deletions
diff --git a/docs/libnm/meson.build b/docs/libnm/meson.build
new file mode 100644
index 0000000000..c275455e40
--- /dev/null
+++ b/docs/libnm/meson.build
@@ -0,0 +1,55 @@
+doc_module = 'libnm'
+
+private_headers = [
+ 'common.h',
+ 'crypto.h',
+ 'nm-dbus-helpers.h',
+ 'nm-core-internal.h',
+ 'nm-core-types-internal.h',
+ 'nm-device-private.h',
+ 'nm-dhcp4-config.h',
+ 'nm-dhcp6-config.h',
+ 'nm-dns-manager.h',
+ 'nm-ip4-config.h',
+ 'nm-ip6-config.h',
+ 'nm-manager.h',
+ 'nm-object-private.h',
+ 'nm-property-compare.h',
+ 'nm-remote-connection-private.h',
+ 'nm-remote-settings.h',
+ 'nm-setting-private.h',
+ 'nm-utils-private.h',
+ 'nm-core-tests-enum-types.h',
+ 'nm-keyfile-internal.h',
+ 'nm-keyfile-utils.h',
+ 'test-general-enums.h'
+]
+
+configure_file(
+ input: version_xml + '.in',
+ output: version_xml,
+ configuration: version_conf
+)
+
+doc_path = join_paths(nm_datadir, 'gtk-doc', 'html', doc_module)
+
+gnome.gtkdoc(
+ doc_module,
+ main_xml: doc_module + '-docs.xml',
+ src_dir: [
+ libnm_core_inc,
+ libnm_inc
+ ],
+ dependencies: libnm_dep,
+ scan_args: [
+ '--rebuild-types',
+ '--rebuild-sections',
+ '--ignore-headers=' + ' '.join(private_headers)
+ ],
+ scanobjs_args: '--type-init-func="g_type_init();"',
+ fixxref_args: '--html-dir=' + doc_path,
+ gobject_typesfile: doc_module + '.types',
+ html_assets: doc_module + '.png',
+ install: true,
+ install_dir: doc_path
+)