summaryrefslogtreecommitdiff
path: root/docs/libnm/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2019-08-28 10:40:46 +0200
committerThomas Haller <thaller@redhat.com>2019-10-01 09:49:33 +0200
commitbfbcf8f3febcba7379f887430c5da16e03e0cf47 (patch)
tree2f528e98082de0bbbd9bbcafe2d7506d83de9d84 /docs/libnm/meson.build
parent50f146f6e3c932e261af16706608a6e0508bbd5f (diff)
downloadNetworkManager-bfbcf8f3febcba7379f887430c5da16e03e0cf47.tar.gz
meson: Use generators placeholders
Functions derived from generators as `configure_file`, `custom_target` and `i18n.merge_file` can use placeholders like `@BASENAME@` that removes the extension from the input filename string. The output string has been replaced by this placeholder that allows in some cases the use of less variables.
Diffstat (limited to 'docs/libnm/meson.build')
-rw-r--r--docs/libnm/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/docs/libnm/meson.build b/docs/libnm/meson.build
index b4a23729bb..7da4061a3d 100644
--- a/docs/libnm/meson.build
+++ b/docs/libnm/meson.build
@@ -27,8 +27,8 @@ private_headers = [
]
configure_file(
- input: version_xml + '.in',
- output: version_xml,
+ input: 'version.xml.in',
+ output: '@BASENAME@',
configuration: version_conf,
)