summaryrefslogtreecommitdiff
path: root/libnm-util/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@redhat.com>2011-10-18 13:48:42 +0200
committerDan Williams <dcbw@redhat.com>2011-11-09 23:16:31 -0600
commita2a0d788182b20b23abc6b33ba1e344084b00b11 (patch)
tree497846a66befefdf45bfd6299a9fc3f7e3e60e9e /libnm-util/Makefile.am
parentd0b71957e788ad820e555f52f99e5ac836e237f8 (diff)
downloadNetworkManager-a2a0d788182b20b23abc6b33ba1e344084b00b11.tar.gz
bonding: settings parser for ifcfg plugin + NMSettingBond class
Introduced a new TYPE=bond for ifcfg-rh configuration files. Alternatively BONDING_MASTER=yes can be specified instead of setting the type explicitely to maintain backwards compatibility with existing configuration files. Bonding device files require a DEVICE= line to be present which specifies the virtual bonding interface in the kernel. We do not allow auto-generation of the name in order to keep confusion to a minimum when reusing existing bonding interfaces. The BONDING_OPTS= parameter can be used to specify various bonding related options, such as: - mode - miimon - updelay - downdelay - arp_interval - arp_ip_target By default, the NMSettingBond class uses a miimon value of 100 which seems like a sensible default value for 99% of all configurations. If this is not suitable, an arp_ip_target needs to be specified manually. A writer is not yet implemented. Changes v2: - renamed DeviceName property to InterfaceName - moved code to validate device name to dev_valid_name() for future use Signed-off-by: Thomas Graf <tgraf@redhat.com>
Diffstat (limited to 'libnm-util/Makefile.am')
-rw-r--r--libnm-util/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libnm-util/Makefile.am b/libnm-util/Makefile.am
index 1327565ae3..627c3e3492 100644
--- a/libnm-util/Makefile.am
+++ b/libnm-util/Makefile.am
@@ -15,6 +15,7 @@ libnm_util_include_HEADERS = \
nm-setting.h \
nm-setting-8021x.h \
nm-setting-bluetooth.h \
+ nm-setting-bond.h \
nm-setting-connection.h \
nm-setting-ip4-config.h \
nm-setting-ip6-config.h \
@@ -44,6 +45,7 @@ libnm_util_la_csources = \
nm-setting.c \
nm-setting-8021x.c \
nm-setting-bluetooth.c \
+ nm-setting-bond.c \
nm-setting-connection.c \
nm-setting-ip4-config.c \
nm-setting-ip6-config.c \