summaryrefslogtreecommitdiff
path: root/libnm-util/Makefile.am
diff options
context:
space:
mode:
authorPavel Šimerda <psimerda@redhat.com>2012-11-05 11:35:34 +0100
committerPavel Šimerda <psimerda@redhat.com>2012-11-13 20:23:06 +0100
commitfaa1bcb540c3dac9bc1a85aa3518f8513fa44417 (patch)
tree512926191fa2514e8753e02513ca59edc5fcd0dc /libnm-util/Makefile.am
parente19ef483b77b724b6ec45c4c3c6106a2f9308769 (diff)
downloadNetworkManager-faa1bcb540c3dac9bc1a85aa3518f8513fa44417.tar.gz
build: improve documentation and test configure options
Use --enable-doc and --enable-tests instead of --with-docs and --with-tests. This is consistent with other features and with --enable-gtk-doc option. Support current variants as fallback. Don't build tests unless --enable-tests is specified.
Diffstat (limited to 'libnm-util/Makefile.am')
-rw-r--r--libnm-util/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libnm-util/Makefile.am b/libnm-util/Makefile.am
index 37d1f1274b..2367925cc0 100644
--- a/libnm-util/Makefile.am
+++ b/libnm-util/Makefile.am
@@ -1,6 +1,6 @@
include $(GLIB_MAKEFILE)
-SUBDIRS=. tests
+SUBDIRS = . tests
INCLUDES = -I${top_srcdir} -I${top_srcdir}/include -I${top_builddir}/include
@@ -164,7 +164,7 @@ typelib_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
CLEANFILES += $(gir_DATA) $(typelib_DATA)
endif
-if WITH_TESTS
+if ENABLE_TESTS
check-local:
$(top_srcdir)/tools/check-exports.sh $(builddir)/.libs/libnm-util.so $(SYMBOL_VIS_FILE)