summaryrefslogtreecommitdiff
path: root/libnm/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-01-28 12:39:38 +0100
committerThomas Haller <thaller@redhat.com>2019-02-01 17:02:57 +0100
commit0420fa1f2c176f5044ff4c17703f5775c43f5804 (patch)
treebec83dfbfc4e00f0542be4e1294c9e29ac8863f1 /libnm/meson.build
parentc8204377d6fce857461b014fc89f51dd427ff45f (diff)
downloadNetworkManager-0420fa1f2c176f5044ff4c17703f5775c43f5804.tar.gz
wifi-p2p: rename files for consistent Wi-Fi P2P naming
We named the types inconsistently: - "p2p-wireless" ("libnm-core/nm-setting-p2p-wireless.h") - "p2p" ("libnm/nm-p2p-peer.h") - "p2p-wifi" ("src/devices/wifi/nm-device-p2p-wifi.h") It seems to me, "libnm/nm-p2p-peer.h" should be qualified with a "Wi-Fi" specific name. It's not just peer-to-peer, it's Wi-Fi P2P. Yes, there is an inconsistency now, because there is already "libnm/nm-access-point.h". It seems to me (from looking at the internet), that the name "Wi-Fi P2P" is more common than "P2P Wi-Fi" -- although both are used. There is also the name "Wi-Fi Direct". But it's not clear which name should be preferred here, so stick to "Wi-Fi P2P". In this first commit only rename the files. The following commit will rename the content.
Diffstat (limited to 'libnm/meson.build')
-rw-r--r--libnm/meson.build18
1 files changed, 9 insertions, 9 deletions
diff --git a/libnm/meson.build b/libnm/meson.build
index dee4e36bdf..f538dbfbaf 100644
--- a/libnm/meson.build
+++ b/libnm/meson.build
@@ -40,30 +40,29 @@ libnm_headers = files(
'nm-device-dummy.h',
'nm-device-ethernet.h',
'nm-device-generic.h',
- 'nm-device.h',
'nm-device-infiniband.h',
'nm-device-ip-tunnel.h',
'nm-device-macsec.h',
'nm-device-macvlan.h',
'nm-device-modem.h',
'nm-device-olpc-mesh.h',
+ 'nm-device-ovs-bridge.h',
'nm-device-ovs-interface.h',
'nm-device-ovs-port.h',
- 'nm-device-ovs-bridge.h',
- 'nm-device-p2p-wifi.h',
'nm-device-ppp.h',
'nm-device-team.h',
'nm-device-tun.h',
'nm-device-vlan.h',
'nm-device-vxlan.h',
+ 'nm-device-wifi-p2p.h',
'nm-device-wifi.h',
'nm-device-wimax.h',
'nm-device-wireguard.h',
'nm-device-wpan.h',
+ 'nm-device.h',
'nm-dhcp-config.h',
'nm-ip-config.h',
'nm-object.h',
- 'nm-p2p-peer.h',
'nm-remote-connection.h',
'nm-secret-agent-old.h',
'nm-types.h',
@@ -71,6 +70,7 @@ libnm_headers = files(
'nm-vpn-editor.h',
'nm-vpn-plugin-old.h',
'nm-vpn-service-plugin.h',
+ 'nm-wifi-p2p-peer.h',
'nm-wimax-nsp.h',
)
@@ -103,7 +103,6 @@ libnm_sources = files(
'nm-device-bond.c',
'nm-device-bridge.c',
'nm-device-bt.c',
- 'nm-device.c',
'nm-device-dummy.c',
'nm-device-ethernet.c',
'nm-device-generic.c',
@@ -113,19 +112,20 @@ libnm_sources = files(
'nm-device-macvlan.c',
'nm-device-modem.c',
'nm-device-olpc-mesh.c',
+ 'nm-device-ovs-bridge.c',
'nm-device-ovs-interface.c',
'nm-device-ovs-port.c',
- 'nm-device-ovs-bridge.c',
- 'nm-device-p2p-wifi.c',
'nm-device-ppp.c',
'nm-device-team.c',
'nm-device-tun.c',
'nm-device-vlan.c',
'nm-device-vxlan.c',
+ 'nm-device-wifi-p2p.c',
'nm-device-wifi.c',
'nm-device-wimax.c',
'nm-device-wireguard.c',
'nm-device-wpan.c',
+ 'nm-device.c',
'nm-dhcp-config.c',
'nm-dhcp4-config.c',
'nm-dhcp6-config.c',
@@ -135,14 +135,14 @@ libnm_sources = files(
'nm-ip6-config.c',
'nm-manager.c',
'nm-object.c',
- 'nm-p2p-peer.c',
'nm-remote-connection.c',
'nm-remote-settings.c',
'nm-secret-agent-old.c',
'nm-vpn-connection.c',
- 'nm-vpn-plugin-old.c',
'nm-vpn-editor.c',
+ 'nm-vpn-plugin-old.c',
'nm-vpn-service-plugin.c',
+ 'nm-wifi-p2p-peer.c',
'nm-wimax-nsp.c',
)