summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-10-16 07:31:56 +0200
committerThomas Haller <thaller@redhat.com>2018-12-20 13:50:34 +0100
commit4b32bbc8201730ab4dd5f56868caa0e9982444de (patch)
tree891c9de1073b27f5910ac0fbda1b44df3f52f529 /meson.build
parent3db4d3acebc17ba29f303aaaa561271c94372249 (diff)
downloadNetworkManager-4b32bbc8201730ab4dd5f56868caa0e9982444de.tar.gz
build: meson: Remove polkit_dir option
meson is able to get variables defined in pkg-config files such as directory paths. PolicyKit defines in its pkg-config file the path to the directory where `policy` files are present. This removes the `polkit_dir` option to ease the move to start using those variables. The `polkit` variable has also been converted to boolean. Fedora spec script has also been updated accordingly.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 1b3d27ef0e..8055e31292 100644
--- a/meson.build
+++ b/meson.build
@@ -462,9 +462,7 @@ endif
config_h.set10('WITH_JSON_VALIDATION', enable_json_validation)
# polkit
-polkit = get_option('polkit')
-enable_polkit = (polkit != 'no')
-
+enable_polkit = get_option('polkit')
if enable_polkit
polkit_dir = get_option('polkit_dir')
if polkit_dir == ''