summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-09-07 16:54:07 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2018-09-13 11:49:25 +0200
commite0c49d7341a0329e2c40e25fee5d3ce249f5ebe6 (patch)
treefeb9b67cf2db7e95c95825434dfea1b0e6f6103f /meson.build
parent9e61ea70402b5d8140de512bdcf84252fcb0d11c (diff)
downloadNetworkManager-e0c49d7341a0329e2c40e25fee5d3ce249f5ebe6.tar.gz
build: remove check on dhcpcd version number
dhcpcd version 6, the first supporting IPv6, was released more than 5 years ago. Remove all checks on version number and IPv6 support.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 0 insertions, 19 deletions
diff --git a/meson.build b/meson.build
index f23f4c388f..14a655d3cd 100644
--- a/meson.build
+++ b/meson.build
@@ -567,29 +567,11 @@ config_h.set10('WITH_DHCLIENT', enable_dhclient)
locations = get_option('dhcpcd')
enable_dhcpcd = (locations != ['no'])
-enable_dhcpcd_supports_ipv6 = false
if enable_dhcpcd
dhcpcd = find_program(locations, required: false)
enable_dhcpcd = dhcpcd.found()
if enable_dhcpcd
- res = run_command(dhcpcd, '--version').stdout().strip()
- dhcpcd_version = res.split(' ')[1]
- if not dhcpcd_version.version_compare('> 4')
- message('Seems version of dhcpcd ' + dhcpcd.path() + ' is too old, version 4.x or newer is required')
- endif
-
- enable_dhcpcd_supports_ipv6 = get_option('dhcpcd_supports_ipv6')
- if dhcpcd_version.version_compare('> 6')
- if not enable_dhcpcd_supports_ipv6
- message('Seems version of dhcpcd ' + dhcpcd.path() + ' supports IPv6, but compiling without IPv6 support.')
- endif
- else
- if enable_dhcpcd_supports_ipv6
- message('Seems version of dhcpcd ' + dhcpcd.path() +' does not support IPv6, but compiling with IPv6 support.')
- endif
- endif
- config_h.set('DHCPCD_SUPPORTS_IPV6', enable_dhcpcd_supports_ipv6)
config_h.set_quoted('DHCPCD_PATH', dhcpcd.path())
endif
endif
@@ -1025,7 +1007,6 @@ if enable_dhcpcd
output += ' ' + dhcpcd.path()
endif
output += '\n'
-output += ' dhcpcd-supports-ipv6: ' + enable_dhcpcd_supports_ipv6.to_string() + '\n'
output += '\nMiscellaneous:\n'
output += ' have introspection: ' + enable_introspection.to_string() + '\n'
output += ' build documentation and manpages: ' + enable_docs.to_string() + '\n'