summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-10-18 12:50:20 +0200
committerThomas Haller <thaller@redhat.com>2018-12-20 13:50:34 +0100
commit35171b3c3f850a9136e48d12ead389ee80842268 (patch)
treeaf3aaf34027fe82e311c5f46d8fbe7c710ed3116 /meson.build
parentb00e004890b9c39fec4fe543bb95fdc263e774bc (diff)
downloadNetworkManager-35171b3c3f850a9136e48d12ead389ee80842268.tar.gz
build: meson: Add trailing commas
Add missing trailing commas that avoids getting noise when another file/parameter is added and eases reviewing changes[0]. [0] https://gitlab.gnome.org/GNOME/dconf/merge_requests/11#note_291585
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 10 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 122ba49495..6b0e1eebe6 100644
--- a/meson.build
+++ b/meson.build
@@ -8,9 +8,9 @@ project(
license: 'GPL2+',
default_options: [
'buildtype=debugoptimized',
- 'c_std=gnu99'
+ 'c_std=gnu99',
],
- meson_version: '>= 0.44.0'
+ meson_version: '>= 0.44.0',
)
nm_name = meson.project_name()
@@ -95,7 +95,7 @@ config_h = configuration_data()
set_defines = [
['GETTEXT_PACKAGE', nm_name],
['PACKAGE_STRING', '@0@ @1@'.format(nm_name, nm_version)],
- ['VERSION', nm_version]
+ ['VERSION', nm_version],
]
foreach define: set_defines
@@ -171,7 +171,7 @@ if nm_debug
'-Wstrict-prototypes',
'-Wtypedef-redefinition',
'-Wundef',
- '-Wunknown-attributes'
+ '-Wunknown-attributes',
]
common_flags += cc.get_supported_arguments(test_cflags)
@@ -223,11 +223,11 @@ gio_unix_dep = dependency('gio-unix-2.0', version: '>= 2.40')
glib_dep = declare_dependency(
dependencies: [
gio_unix_dep,
- dependency('gmodule-2.0')
+ dependency('gmodule-2.0'),
],
compile_args: [
'-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_40',
- '-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_40'
+ '-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_40',
]
)
@@ -761,7 +761,7 @@ test_args = [
'',
enable_valgrind ? valgrind.path() : '',
enable_valgrind ? valgrind_suppressions_path : '',
- '--launch-dbus=auto'
+ '--launch-dbus=auto',
]
py3 = import('python3')
@@ -877,7 +877,7 @@ config = 'config.h'
configure_file(
input: config + '.meson',
output: config,
- configuration: config_h
+ configuration: config_h,
)
config_extra_h = configuration_data()
@@ -907,7 +907,7 @@ config_extra_h.set_quoted('SYSCONFDIR', nm_sysconfdir)
configure_file(
input: 'config-extra.h.meson',
output: 'config-extra.h',
- configuration: config_extra_h
+ configuration: config_extra_h,
)
meson.add_install_script(
@@ -918,7 +918,7 @@ meson.add_install_script(
nm_pkglibdir,
nm_pkgstatedir,
enable_docs ? 'install_docs' : '',
- nm_mandir
+ nm_mandir,
)
output = '\nSystem paths:\n'