summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-03-05 08:44:57 +0100
committerLubomir Rintel <lkundrak@v3.sk>2019-03-19 17:15:15 +0100
commit1de8383ad9fdfc8f552117e5d109bdfa7005634b (patch)
tree7b44996c8430157f2739b18148952859ea9e6b5f /meson.build
parent32e0bf1421263b07a1dde74d9281253cc1ea49ab (diff)
downloadNetworkManager-1de8383ad9fdfc8f552117e5d109bdfa7005634b.tar.gz
all: goodbye libnm-glib
This removes libnm-glib, libnm-glib-vpn, and libnm-util for good. The it has been replaced with libnm since NetworkManager 1.0, disabled by default since 1.12 and no up-to-date distributions ship it for years now. Removing the libraries allows us to: * Remove the horrible hacks that were in place to deal with accidental use of both the new and old library in a single process. * Relief the translators of maintenance burden of similar yet different strings. * Get rid of known bad code without chances of ever getting fixed (libnm-glib/nm-object.c and libnm-glib/nm-object-cache.c) * Generally lower the footprint of the releases and our workspace If there are some really really legacy users; they can just build libnm-glib and friends from the NetworkManager-1.16 distribution. The D-Bus API is stable and old libnm-glib will keep working forever. https://github.com/NetworkManager/NetworkManager/pull/308
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build37
1 files changed, 0 insertions, 37 deletions
diff --git a/meson.build b/meson.build
index ee74e54d76..a6643473f9 100644
--- a/meson.build
+++ b/meson.build
@@ -63,28 +63,6 @@ libnm_version = '@0@.@1@.@2@'.format(current - age, age, revision)
libnm_pkgincludedir = join_paths(nm_includedir, libnm_name)
-libnm_util_name = 'libnm-util'
-
-current = 9
-revision = 0
-age = 7
-libnm_util_version = '@0@.@1@.@2@'.format(current - age, age, revision)
-
-libnm_glib_name = 'libnm-glib'
-libnm_glib_vpn_name = libnm_glib_name + '-vpn'
-
-current = 13
-revision = 0
-age = 9
-libnm_glib_version = '@0@.@1@.@2@'.format(current - age, age, revision)
-
-libnm_glib_pkgincludedir = join_paths(nm_includedir, libnm_glib_name)
-
-current = 3
-revision = 0
-age = 2
-libnm_glib_vpn_version = '@0@.@1@.@2@'.format(current - age, age, revision)
-
nm_debug = get_option('buildtype').contains('debug')
cc = meson.get_compiler('c')
@@ -320,15 +298,6 @@ if enable_introspection
assert(gir_dep.found(), 'introspection support was requested, but the gobject-introspection library is not available. Use -Dintrospection=false to build without it.')
endif
-enable_libnm_glib = get_option('libnm_glib')
-if enable_libnm_glib
- dbus_glib_dep = dependency('dbus-glib-1', version: '>= 0.94', required: false)
- assert(dbus_dep.found() and dbus_glib_dep.found(), 'Configure with -Dlibnm_glib=false if you do not need the legacy libraries')
-endif
-# FIXME: do this better!!!
-have_fake_typelibs = enable_libnm_glib and enable_introspection
-config_h.set10('WITH_FAKE_TYPELIBS', have_fake_typelibs)
-
udev_dir = get_option('udev_dir')
install_udev_dir = (udev_dir != 'no')
@@ -857,11 +826,6 @@ subdir('clients')
subdir('data')
subdir('po')
-if enable_libnm_glib
- subdir('libnm-util')
- subdir('libnm-glib')
-endif
-
if enable_vapi
subdir('vapi')
endif
@@ -972,7 +936,6 @@ output += ' ofono: ' + enable_ofono.to_string() + '\n'
output += ' concheck: ' + enable_concheck.to_string() + '\n'
output += ' libteamdctl: ' + enable_teamdctl.to_string() + '\n'
output += ' ovs: ' + enable_ovs.to_string() + '\n'
-output += ' libnm-glib: ' + enable_libnm_glib.to_string() + '\n'
output += ' nmcli: ' + enable_nmcli.to_string() + '\n'
output += ' nmtui: ' + enable_nmtui.to_string() + '\n'
output += '\nConfiguration_plugins (main.plugins=' + config_plugins_default + ')\n'