summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-02-08 15:14:35 +0100
committerThomas Haller <thaller@redhat.com>2019-02-08 20:14:50 +0100
commit7b18bd1fa8e7efff4e0c14818d5d876f7b25f15a (patch)
tree2ba383b3d73d066284c8c06f76e6d96164502169 /meson.build
parentdc4f6f665689a0f3b269cd8465888fbeb2f40fd5 (diff)
downloadNetworkManager-7b18bd1fa8e7efff4e0c14818d5d876f7b25f15a.tar.gz
build/meson: disable "-Wgnu-variable-sized-type-not-at-end warning"
It's not useful for us. In file included from ../src/systemd/src/libsystemd/sd-event/sd-event.c:14: ../src/systemd/src/libsystemd/sd-event/event-source.h:195:36: error: field 'buffer' with variable sized type 'union inotify_event_buffer' not at the end of a struct or class is a GNU extension [-Werror,-Wgnu-variable-sized-type-not-at-end] union inotify_event_buffer buffer; ^
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3368289c11..24a3b04efe 100644
--- a/meson.build
+++ b/meson.build
@@ -158,7 +158,6 @@ endif
if nm_debug
common_flags += cc.get_supported_arguments([
- '-fno-strict-aliasing',
'-Wdeclaration-after-statement',
'-Wfloat-equal',
'-Wimplicit-fallthrough',
@@ -169,6 +168,7 @@ if nm_debug
'-Wmissing-prototypes',
'-Wno-duplicate-decl-specifier',
'-Wno-format-truncation',
+ '-Wno-gnu-variable-sized-type-not-at-end',
'-Wno-missing-braces',
'-Wno-missing-field-initializers',
'-Wno-pragmas',
@@ -181,6 +181,7 @@ if nm_debug
'-Wtypedef-redefinition',
'-Wundef',
'-Wunknown-attributes',
+ '-fno-strict-aliasing',
])
endif