summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2019-02-02 15:57:01 +0100
committerBeniamino Galvani <bgalvani@redhat.com>2019-02-04 10:55:25 +0100
commite6cf4213a774020cfcc27983354c81b3e92caa9e (patch)
tree4b97a890410d4f34af1d3ac69295f5a98451a98f /meson.build
parentb114b00f0a52d8c3800ccb3f4e461d4ea9c7c20b (diff)
downloadNetworkManager-e6cf4213a774020cfcc27983354c81b3e92caa9e.tar.gz
build: fix building with LTO
Building with link-time optimization requires some tricks explained in [1]. [1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=48200#c28
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c9307a6cad..0f2d946169 100644
--- a/meson.build
+++ b/meson.build
@@ -147,6 +147,15 @@ if enable_ld_gc
common_ldflags += test_ldflags
endif
+enable_lto = get_option('b_lto')
+if enable_lto
+ # meson already adds '-flto'
+ lto_flag = '-flto-partition=none'
+ assert(cc.has_argument(lto_flag), '-flto-partition=none not supported. Disable link-time optimization with -Db_lto=false.')
+ common_flags += lto_flag
+ common_ldflags += lto_flag
+endif
+
if nm_debug
common_flags += cc.get_supported_arguments([
'-fno-strict-aliasing',
@@ -986,7 +995,7 @@ if enable_valgrind
endif
output += '\n'
output += ' code coverage: ' + get_option('b_coverage').to_string() + '\n'
-output += ' LTO: ' + get_option('b_lto').to_string() + '\n'
+output += ' LTO: ' + enable_lto.to_string() + '\n'
output += ' Linker garbage collection: ' + enable_ld_gc.to_string() + '\n'
output += ' JSON validation for libnm: ' + enable_json_validation.to_string() + '\n'
output += ' crypto: ' + crypto + ' (have-gnutls: ' + crypto_gnutls_dep.found().to_string() + ', have-nss: ' + crypto_nss_dep.found().to_string() + ')\n'