summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-11-22 15:59:11 +0100
committerThomas Haller <thaller@redhat.com>2019-11-22 16:07:02 +0100
commit21845ae4e342bca61ad71a1ec6ba239df805eb76 (patch)
tree35a9930b526709f22ea38be760be5a0a8c462a42 /meson.build
parent6d7270e222cce3edaf95c463bec9f3212f5e5c73 (diff)
downloadNetworkManager-21845ae4e342bca61ad71a1ec6ba239df805eb76.tar.gz
build/meson: cleanup "meson-post-install.sh"
- the variables in meson.build and in the meson-post-install.sh script should have the same names. - the positional command line arguments should be assigned to variables, because the variable name acts like a documentation what the variable means (contrary to the argument number). - the boolean flags should not map to other special values, like "enable_docs ? 'install_docs' : ''". The name "enable_docs" is good already, it shall be either passed as 1 or 0 and use the name consistently.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 29da0b0504..ec2f5a94a8 100644
--- a/meson.build
+++ b/meson.build
@@ -906,10 +906,10 @@ meson.add_install_script(
nm_pkgconfdir,
nm_pkglibdir,
nm_pkgstatedir,
- enable_docs ? 'install_docs' : '',
nm_mandir,
- enable_ifcfg_rh ? 'create_network_scripts' : '',
nm_sysconfdir,
+ enable_docs ? '1' : '0',
+ enable_ifcfg_rh ? '1' : '0',
)
output = '\nSystem paths:\n'