summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-04-12 11:59:56 +0200
committerThomas Haller <thaller@redhat.com>2022-04-15 09:04:30 +0200
commit5da17c689be5e66ea2f63dea6f1846625e652998 (patch)
treee1813b362c7188faf25e3cb0f79d7fb825942bdf /meson.build
parentbbbb1b733946ed9e16a9153bf6f541dbbc8d9ff9 (diff)
downloadNetworkManager-5da17c689be5e66ea2f63dea6f1846625e652998.tar.gz
dns/unbound: drop deprecated "unbound" DNS plugin
The "unbound" DNS plugin was very rudimentary and is deprecated since commit 4a2fe09853cd ('man: mark [main].dns=unbound as deprecated') (Jun 2021). It is part of dnssec-trigger tool, but the dnssec-trigger tool doesn't actually use it. Instead it installs a dispatcher script "/usr/lib/NetworkManager/dispatcher.d/01-dnssec-trigger". Especially, since the plugin requires "/usr/libexec/dnssec-trigger-script", which is provided by "dnssec-trigger" package on Fedora. At the same time, the package provides the dispatcher script. So I don't this works or anybody is using this. https://mail.gnome.org/archives/networkmanager-list/2022-April/msg00002.html
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 3 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 45d6970894..edf4b377fa 100644
--- a/meson.build
+++ b/meson.build
@@ -683,18 +683,11 @@ endforeach
# external misc tools paths
default_paths = ['/sbin', '/usr/sbin']
-dnssec_ts_paths = ['/usr/local/libexec',
- '/usr/local/lib',
- '/usr/local/lib/dnssec-trigger',
- '/usr/libexec',
- '/usr/lib',
- '/usr/lib/dnssec-trigger']
# 0: cmdline option, 1: paths, 2: fallback
-progs = [['iptables', default_paths, '/usr/sbin/iptables'],
- ['nft', default_paths, '/usr/sbin/nft'],
- ['dnsmasq', default_paths, ''],
- ['dnssec_trigger', dnssec_ts_paths, join_paths(nm_libexecdir, 'dnssec-trigger-script') ],
+progs = [['iptables', default_paths, '/usr/sbin/iptables'],
+ ['nft', default_paths, '/usr/sbin/nft'],
+ ['dnsmasq', default_paths, ''],
]
foreach prog : progs