summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-05-11 15:23:25 +0200
committerThomas Haller <thaller@redhat.com>2022-05-11 15:29:45 +0200
commitc840e56e0ac0a4518c0fdf91a6b7362a4e1eb636 (patch)
tree276ac2a9c0576ab48ebd01b375e29d2995638c72 /meson.build
parent331a7c9943211c4b161135833f6cc393f3cd692e (diff)
downloadNetworkManager-c840e56e0ac0a4518c0fdf91a6b7362a4e1eb636.tar.gz
meson/build: fix using correct prefix for "systemdsystemunitdir"
We do the same with autotools. Well, almost the same. Of course, meson's define_variable only accepts a list of two strings, to define one variable. So we cannot also redefine "prefix", unlike configure.ac.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 84b283e60f..a4814550ae 100644
--- a/meson.build
+++ b/meson.build
@@ -369,7 +369,7 @@ install_systemdunitdir = (systemd_systemdsystemunitdir != 'no')
if install_systemdunitdir and systemd_systemdsystemunitdir == ''
assert(systemd_dep.found(), 'systemd required but not found, please provide a valid systemd user unit dir or disable it')
- systemd_systemdsystemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
+ systemd_systemdsystemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir', define_variable: ['rootprefix', nm_prefix])
endif
enable_systemd_journal = get_option('systemd_journal')