summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-01-10 10:29:11 +0100
committerThomas Haller <thaller@redhat.com>2018-01-10 12:31:44 +0100
commit349861ceec4085fd1f0ff0af8bcf873aa15ba611 (patch)
tree6543ad02add282e0c3c0a62d632d607f93659eaa /meson.build
parentec016f6b43f4f7727944d67e358e7dc01ee2e42d (diff)
downloadNetworkManager-349861ceec4085fd1f0ff0af8bcf873aa15ba611.tar.gz
build/meson: unconditionally use linker version scripts
We also unconditionally use them with autotools. Also, the detection for have_version_script does not seem correct to me. At least, it didn't work with clang.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 8fb9d92ff3..5a565e5a5c 100644
--- a/meson.build
+++ b/meson.build
@@ -165,9 +165,6 @@ endif
add_project_arguments(common_flags, language: 'c')
add_project_link_arguments(common_ldflags, language: 'c')
-ldflag = '-Wl,--version-script'
-have_version_script = host_machine.system().contains('linux') and cc.has_argument(ldflag)
-
linker_script_binary = join_paths(meson.source_root(), 'linker-script-binary.ver')
linker_script_devices = join_paths(meson.source_root(), 'linker-script-devices.ver')
linker_script_settings = join_paths(meson.source_root(), 'linker-script-settings.ver')