summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-01-14 14:19:20 +0100
committerThomas Haller <thaller@redhat.com>2018-01-15 20:29:26 +0100
commitcd6116e58f863202a9072b97fc32b1b50f9e1ba3 (patch)
tree312e6ab83ad42294666e76dbac70131b980600f7 /meson.build
parenta3f77b259cea16f32d6428cbba03f0409b1dd96e (diff)
downloadNetworkManager-cd6116e58f863202a9072b97fc32b1b50f9e1ba3.tar.gz
wifi: remove configure checks for suitable linux/nl80211.h header
The check doesn't seem useful, because it does not result in a fallback or a different build. Just assume <linux/nl80211.h> is valid. In case it is not, we will get a build failure later. That is just as good.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 0 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index b3bb97189c..6942103f27 100644
--- a/meson.build
+++ b/meson.build
@@ -269,23 +269,6 @@ if dist_version != ''
endif
enable_wifi = get_option('wifi')
-if enable_wifi
- nl80211_src = '''
- #ifndef __user
- #define __user
- #endif
- #include <sys/types.h>
- #include <linux/types.h>
- #include <sys/socket.h>
- #include <linux/nl80211.h>
- int main() {
- int a = NL80211_RATE_INFO_BITRATE;
- a++;
- }
- '''
-
- assert(cc.compiles(nl80211_src), 'Linux kernel development header linux/nl80211.h not installed or not functional')
-endif
config_h.set10('WITH_WIFI', enable_wifi)
enable_iwd = get_option('iwd')