summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2018-03-18 21:19:41 +0100
committerLubomir Rintel <lkundrak@v3.sk>2018-05-09 12:59:39 +0200
commit6aac441f1ce9f74ccb9dd2d97d3330be3eec0cef (patch)
tree54367c92b370a940c73a6cbc691f58f2f1303679 /meson.build
parent84a6010718c47953c64a7dcd4d0fc7f435aa1bbf (diff)
downloadNetworkManager-6aac441f1ce9f74ccb9dd2d97d3330be3eec0cef.tar.gz
meson: distinguish arch specific and arch neutral lib dir
Plugins go to the arch specific place while conf.d/ and VPN/ are in lib/. Use the same naming as is used with autoconf.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 994916778a..dc1524aa0d 100644
--- a/meson.build
+++ b/meson.build
@@ -42,9 +42,10 @@ nm_pkgsbindir = join_paths(nm_sbindir, nm_name)
nm_pkgconfdir = join_paths(nm_sysconfdir, nm_name)
nm_pkgdatadir = join_paths(nm_datadir, nm_name)
nm_pkgincludedir = join_paths(nm_includedir, nm_name)
-nm_pkglibdir = join_paths(nm_libdir, nm_name)
+nm_pkglibdir = join_paths(nm_prefix, 'lib', nm_name)
nm_pkgrundir = join_paths(nm_runstatedir, nm_name)
nm_pkgstatedir = join_paths(nm_localstatedir, nm_name)
+nm_plugindir = join_paths(nm_libdir, nm_name)
libnm_name = 'libnm'
@@ -886,6 +887,7 @@ output += ' nmlibdir: ' + nm_pkglibdir + '\n'
output += ' nmdatadir: ' + nm_pkgdatadir + '\n'
output += ' nmstatedir: ' + nm_pkgstatedir + '\n'
output += ' nmrundir: ' + nm_pkgrundir + '\n'
+output += ' nmplugindir: ' + nm_plugindir + '\n'
output += '\nPlatform:\n'
output += ' session tracking: ' + ','.join(session_trackers) + '\n'
output += ' suspend/resume: ' + suspend_resume + '\n'