summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-04-11 10:49:33 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2018-04-12 09:21:10 +0200
commita2479b95c0d44d3d5cea77ce1703407b4be6fb92 (patch)
treeb9d38c9c7649b016bd5262c64ba3834b1abffd42 /meson.build
parent3b5a522ef6e212772590ad8a569864ba82b91c9f (diff)
downloadNetworkManager-a2479b95c0d44d3d5cea77ce1703407b4be6fb92.tar.gz
build: meson: use run-nm-test.sh to run tests
Like autotools, use the wrapper script 'run-nm-test.sh' that starts a separate D-Bus session when needed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 65f1f89018..5f29c16a69 100644
--- a/meson.build
+++ b/meson.build
@@ -209,8 +209,6 @@ have_systemd_200 = systemd_dep.found() and systemd_dep.version().version_compare
gio_unix_dep = dependency('gio-unix-2.0', version: '>= 2.40')
-log_driver = join_paths(meson.source_root(), 'build-aux', (gio_unix_dep.version().version_compare('>= 2.37.6') ? 'tap-driver.sh' : 'test-driver'))
-
glib_dep = declare_dependency(
dependencies: [
gio_unix_dep,
@@ -724,6 +722,7 @@ endif
tests = get_option('tests')
enable_tests = (tests != 'no')
require_root_tests = (tests == 'root')
+test_script = find_program(join_paths(meson.source_root(), 'tools', 'run-nm-test.sh'))
# valgrind
locations = get_option('valgrind')
@@ -740,6 +739,14 @@ if enable_valgrind
endif
endif
+test_args = [
+ '--called-from-make',
+ '',
+ enable_valgrind ? valgrind.path() : '',
+ enable_valgrind ? valgrind_suppressions_path : '',
+ '--launch-dbus=auto'
+]
+
# FIXME
#AC_SUBST(NM_LOG_COMPILER, 'LOG_COMPILER = "$(top_srcdir)/tools/run-nm-test.sh" --called-from-make "$(LIBTOOL)" "$(with_valgrind)" "'"$with_valgrind_suppressions"'" --launch-dbus=auto')